Extensible Messaging and Presence Protocol

Extensible Messaging and Presence Protocol (XMPP) (tidligere Jabber[1]) er en åpen, XML-basert internettprotokoll for direktemeldinger og tilstedeværelsesinformasjon. XMPP-basert programvare er i bruk på tusenvis av tjenere over hele internett, og brukes av over ti millioner mennesker verden over, ifølge XMPP Standard Foundation (tidligere Jabber Software Foundation[2]).
Jeremie Miller startet prosjektet i 1998, og det første offentlige programslippet skjedde i mai 2000. Prosjektets hovedprodukt er jabberd, en tjener som XMPP-klienter kan koble seg til for å komme seg på XMPP. Denne tjeneren kan enten danne et privat XMPP-nettverk (eksempelvis bak en brannmur), eller den kan tilslutte seg det globale, offentlige XMPP-nettverket.

Transportører
[rediger | rediger kilde]Et nøkkelkonsept bak XMPP-systemet er transportører, også kjent som gateways, som tillater brukere tilgang til direktemeldingsnettverk som bruker andre protokoller, slik som AIM, ICQ, Windows Live Messenger og Windows Messenger, SMS eller e-post. Til forskjell fra multiprotokoll-klienter som Pidgin eller Kopete, gir XMPP denne tilgangen på tjenernivå ved å kommunisere over spesielle transporttjenester som kjører på en tjener langt borte. Enhver XMPP-bruker kan «registrere seg» hos en av disse transportørene ved å oppgi nødvendig informasjon for å logge seg på det bestemte nettverket, og kan deretter kommunisere med brukere av det nettverket som om de også var XMPP-brukere. Dette betyr at enhver klient med fullstendig støtte for XMPP-protokollen kan brukes for å koble seg på ethvert nettverk som en transport eksisterer for, uten at det behøves noe ekstra kode i klienten. Transportsystemet er ment å lette overgangen til XMPP mens markedet ennå er fullt av proprietære direktemeldingstjenester.
Standardiserte direktemeldinger
[rediger | rediger kilde]Grunnlaget for protokollen, som nå styres av XMPP Standards Foundation, har blitt sendt som et standardiseringsforslag til IETF under navnet XMPP, og blitt godkjent som den offisielle standarden for direktemeldinger. SIMPLE, en konkurrerende standard basert på SIP-protokollen, konkurrerer om den samme statusen.
XMPP-klienter
[rediger | rediger kilde]Her lister vi opp en rekke klienter som støtter XMPP.
Rene XMPP-klienter
[rediger | rediger kilde]- Akeni Jabber Client (Kryssplattform, produsenteid (gratis for ikke-kommersiell bruk)) http://www.akeni.com
- Coccinella IM (kryssplattform, fri programvare) https://web.archive.org/web/20061205015549/http://hem.fyristorg.com/matben/
- Gabber (for GNOME, GPL)
- Gossip (for GNOME, GPL) https://web.archive.org/web/20050120035820/http://www.imendio.com/projects/gossip/
- JBother (for Java) https://web.archive.org/web/20050309195135/http://linuxhelp.homeunix.com/cgi-bin/rblh/index.rb?handler=downloads&d=jbother
- Psi/Psi+ (kryssplattform, GPL) https://psi-im.org/
- Tkabber (kryssplattform, fri programvare) https://tkabber.jabber.ru/
- Gajim (kryssplattform, fri programvare) https://gajim.org/
Multiprotokoll-klienter
[rediger | rediger kilde]- Bitlbee via IRC (Kryssplattform, fri programvare) https://www.bitlbee.org/
- Centericq (Kryssplattform, GPL)
- Fire (Mac OS X, GPL)
- Pidgin (GPL)
- Kopete (GPL) http://kopete.kde.org/ Arkivert 26. mai 2008 hos Wayback Machine.
- SIM (GPL) http://sim-icq.sourceforge.net/
- Trillian
- iChat fra Apple
Referanser
[rediger | rediger kilde]- ↑ Jabber Inc. – About Us Arkivert 3. juli 2007 hos Wayback Machine.
- ↑
Eksterne lenker
[rediger | rediger kilde]- (en) Offisielt nettsted
- (en) Extensible Messaging and Presence Protocol – kategori av bilder, video eller lyd på Commons
- (en) XMPP Extensions
- (en) XMPP Software: Clients
- (en) XMPP Software: Servers
- (en) Public XMPP Services Arkivert 4. november 2010 hos Wayback Machine.
- (en) Jabber.org (Free XMPP server of the XSF)
- (no) Jabber Norge, åpen, norsk, sikker, jabberserver Arkivert 28. april 2005 hos Wayback Machine.
- (en) Planet Jabber – Om hva som rører seg i jabber-miljøet.
- XMPP-RFCer: RFC 3920 RFC 3921 RFC 3922 RFC 3923